Debian Horror: la notte dei morti viventi!!!

Era un po’ che mi frullava nella testa l’idea di provare a realizzare un’installazione di Debian Etch usando la modalità Net Install… Alla fine mi sono deciso: era venuto il momento di dire addio alla Slacware installata sul mio Acer Extensa 355!

mini_extensa_09.jpg

E’ così che è iniziata “la notte dei morti viventi”: ovvero come riportare in vita un vecchio portatile altrimenti inesorabilmente destinato a fungere da appoggio per la polvere nei secoli dei secoli 😛

L’Extensa 355 è un vecchio portatile che ho acquistato qualche anno fa da un conoscente per 50 mila lire 😛 .
Con un processore a 133 MHz, 48 MB di RAM, 1 MB di memoria video e nessun lettore CD a disposizione l’impresa sembava tremendamente difficile ed allo stesso tempo tremendamente allettante 😀
Così alle 21.30 circa, dopo aver fatto il backup dei pochi dati presenti, sono entrato in sala operatoria!

Utilizzando un’altro pc ho scaricato dal sito ufficiale di Debian le immagini raw dei floppy disk di boot:

  • boot.img
  • cd-drivers.img
  • net-drivers-1.img
  • net-drivers-2.img
  • root.img

Giusto per essere sicuri di non annoiarsi, i problemi sono cominciati subito: l’altro pc era troppo recente e non aveva il drive del floppy per scrivere le immagini sui dischetti. Così ho copiato via rete i file sull’Extensa e, utilizzando la Slackware presente, ho creato i 5 floppy disk di avvio con il comando:

dd if=nomefile of=/dev/fd0 bs=1024 conv=sync ; sync

Tutto contento infilo nel lettore il primo floppy e riavvio il portatile.

mini_installazione_01.jpg

L’installazione parte e dopo aver caricato il necessario mi chiede di inserire il floppy di root

mini_installazione_02.jpg

Carica anche il secondo floppy e finalmente parte l’installazione vera e propria.

mini_installazione_03.jpg

Un messaggio mi avvisa che l’installer, essendosi accorto di avere poca RAM a disposizione, è partito in modalità “Low memory” e che una delle conseguenze principali di ciò sarà che tutto il processo di installazione verrà effettuato in inglese. Poco male, l’inglese informatico lo conosco :D, proseguiamo…

mini_installazione_04.jpg

Il passo successivo è la scelta della lingua: scelgo Italy

mini_installazione_05.jpg

E’ il momento di caricare i driver necessari per la scheda di rete PCMCIA (credevate forse che l’Extensa avesse una scheda di rete integrata?!?! 😛 ) così inserisco il primo floppy con i driver di rete…
Evvai! Tra un po’ si comincia con l’installazione!
La barra di avanzamento carica fino a metà, impiegando un tempo infinito finchè…

mini_installazione_05a.jpg

Sta scherzando penso, ovviamente sta scherzando… continuo fiducioso e spavaldo ma… l’installazione si blocca miseramente!
Nooo!!!!!!! Devo ricominciare da capo!!! Ok pazienza, tanto si fa subito…
Rifaccio tutto il procedimento fino ad inserire il primo dischetto dei driver di rete e… boom
Ok, ho capito, non stava scherzando! In una frazione di secondo realizzo che il fottuto dischetto deve essere danneggiato: ne prendo uno nuovo, ci scrivo l’immagine, faccio di nuovo tutta la trafila e finalmente funziona!

mini_installazione_06.jpg

Carico anche i driver del secondo dischetto

mini_installazione_07.jpg

A questa ulteriore richiesta di caricare i driver da floppy rispondo negativamente tanto, mi dico, è inutile caricare i driver per i lettori cd se non ne ho uno a disposizione…
Mi pare logico no?! E invece no! E vi dirò perchè: andando avanti nel processo di installazione si arriverà al un punto in cui si dovrà partizionare l’hard disk. Ora, un requisito fondamentale per il partizionamento di un disco rigido, è che il computer identifichi correttamente il disco rigido poichè non è possibile partizionare qualcosa che non c’è (o meglio, che il computer dice che non c’è anche se c’è 😦 )
Ebbene si avete capito! Senza caricare i fottuti driver dei lettori cd il mio cazzo di hard disk ATA da 40 GB non veniva riconosciuto, poichè nel sistema standard di installazione non veniva caricato di default anche il driver ide-scsi che è quello che serve al sistema per riconoscere il mio disco rigido (l’ho scoperto ricaricando la Slackware che non era ancora stata rasa al suolo e guardando i moduli caricati con lsmod).
Avrete capito anche che ho dovuto rifare un’altra volta l’installazione da capo 😛

mini_installazione_09.jpg

Scelgo il layout della tastiera: Italian

mini_installazione_10.jpg

Questo messaggio mi avvisa che l’installer non ha potuto montare il cdrom perchè non c’è (e io che ti avevo detto?! 😛 ) e mi chiede se voglio riprovare, ovviamente dico di no

mini_installazione_11.jpg

mini_installazione_12.jpg

Un messaggio di errore mi avvisa che il passo dell’installazione che prevedeva di caricare il cd rom è fallito (vi confesso che qui ho temuto il peggio) poi mi ritrovo sul menù principale che mi permette di scegliere quale passo dell’installazione eseguire: poichè voglio tentare l’installazione di rete, scelgo Detect network hardware

mini_installazione_13.jpg

Questa schermate mi fa una di quelle domande che non ci si vorrebbe mai sentir rivolgere: mi chiede se la mia scheda di rete PCMCIA ha bisogno di opzioni particolari per funzionare…
Ma che ne so?!?!?! Lascio vuoto il campo e proseguo incrociando le dita: nell’informatica ci vuole anche tanta fortuna 😀

mini_installazione_14.jpg

Rete configurata correttamente! Grande! Allora Dio esiste! 😛

mini_installazione_15.jpg

Scelgo il nome da dare al mio computer

mini_installazione_16.jpg

Lascio il nome del dominio rilevato dall’installer

mini_installazione_17.jpg

mini_installazione_18.jpg

Scelgo la nazione dove cercare i mirror per i pacchetti e poi sceglo uno di quelli proposti

mini_installazione_19.jpg

Non ho bisogno di proxy quindi vado avanti

mini_installazione_20.jpg

mini_installazione_21.jpg

Vengono insallati i primi componenti e poi viene fatto il rilevamento dei dischi e dell’hardware

mini_installazione_22.jpg

Avvio del programma di partizionamento

mini_installazione_23.jpg

Scelgo il partizionamento guidato

mini_installazione_24.jpg

Gli dico di usare l’intero disco

mini_installazione_25.jpg

Seleziono il disco da partizionare

mini_installazione_26.jpg

Scelgo di tenere la root e la home in partizioni separate

mini_installazione_27.jpg

mini_installazione_28.jpg

Confermo tutte le scelte e dico di scrivere le modifiche su disco
Bye bye Slackware 😉

mini_installazione_29.jpg

mini_installazione_30.jpg

Imposto la password di root

mini_installazione_31.jpg

mini_installazione_32.jpg

Creo il mio utente… si uso crash e con questo?! Lo so che vuol dire ma mi piace come suona 🙂 E poi c’è una canzone di Bon Jovi intitolata “Captain Crash and The Beauty Queen From Mars”: non sono il solo a cui piace quel nome 😛

mini_installazione_33.jpg

mini_installazione_34.jpg

Imposto la password per il mio utente…

mini_installazione_35.jpg

Ci siamo! Finalmente l’installazione è iniziata!
Con enorme sorpresa mi accorgo che, tra un problema e l’altro, ho già superato abbondantemente la mezzanotte.
Sono a pezzi, mi riprometto di finire solo l’installazione del sistema di base e poi a ninna…
Ci sarà da aspettare, questo è un buon momento per uscire in balcone a fumare una sigaretta 🙂

panorama.jpg

Che pace… dopo la mezzanotte si sente solo il vento ed il rumore di qualche macchina che passa da lontano

mini_installazione_37.jpg

Quando torno dentro, dopo la mia piccola pausa è quasi terminata l’installazione del sistema di base.
Mi chiede se voglio partecipare al popularity contest… sinceramente non ne ho voglia, quindi rispondo di no (non si fanno queste domande a quest’ora 😛 )

mini_installazione_38.jpg

Scelgo di installare un sistema minimale solo con i pacchetti delle categorie Laptot e Standard system poichè non voglio che mi vengano installati Gnome e/o KDE, tanto con 48 MB di RAM non riuscirebbero nemmeno a partire.
Preferisco installare più tardi, a mano, Xfce che ritengo sia un giusto compromesso tra leggerezza (fondamentale per funzionare su un vecchio pc come questo) e bellezza (fondamentale per non farmi passare la voglia di usare questo vecchio pc 😛 )

mini_installazione_39.jpg

Rispondo affermativamente quando mi viene chiesto se voglio installare GRUB nell’MBR

mini_installazione_40.jpg

Ci siamo, installazione terminata… è il momento della verità

mini_extensa_03.jpg

Ecco GRUB sul mio Extensa

mini_installazione_41.jpg

Il sistema si avvia senza problemi. Giusto per curiosità provo ad installare qualche pacchetto dalla rete ma…
Ma porca puttana!!! Ho fatto un’installazione intera con quella scheda di rete ed ora non la riconosci?!?!
A questo punto è una questione di principio: DEVE FUNZIONARE!!!
Dopo una bella sfilata di santi e divinità varie… mi metto a cercare su Google (cazzo dovrei essere a letto!)
Alla fine scopro che è necessario caricare il modulo i82365 all’avvio altrimenti il controller PCMCIA non ci pensa nemmeno per scherzo di attivarsi. Verificato il funzionamento caricando il modulo a mano con modprobe, aggiungo una riga a /etc/modules che dice di caricarlo all’avvio.

Adesso basta, sono le 3.30 e vado davvero a nanna. 😀

Il giorno seguente la strada è QUASI tutta in discesa:

Installo:

apt-get install xorg
apt-get install kdm
apt-get install xfce4
apt-get install alsa

Eseguo alsaconf per far impostare la scheda audio

mini_extensa_05.jpg

Schermata di login di KDM

Ho editato il file /etc/X11/xorg.conf (il QUASI di prima era riferito a questo 😦 ):

cambiando il driver nella sezione Device in “chips”
aggiungendo l’opzione “no_stretch” nella sezione Device
aggiungendo ModeLine “800×590” 28.322 800 808 848 936 590 600 604 628 nella sezione monitor

mini_extensa_06.jpg

L’avvio di Xfce

Installo synaptic che può sempre servire 😀 :

apt-get install synaptic
apt-get install gksu

mini_extensa_10.jpg

Primo avvio di Xfce

Installo iceweasel (firefox) per internet, gaim per la chat e xmms per la musica:

apt-get install iceweasel
apt-get install gaim
apt-get install xmms

mini_extensa_08.jpg

Xfce dopo un po’ di personalizzazione

Installo un po’ di figate di xfce, (plugin per xmms, monitor di tempo e temperatura, ecc 😀 ):

apt-get install xfce4-goodies
apt-get install xfce4-mixer
apt-get install xfce4-xmms-plugin

Installo samba per connettermi anche alle macchine non GNU/Linux:

apt-get install samba
apt-get install smbclient
apt-get install smbfs

Dulcis in fundo i soliti lbreakout2 e xmame

apt-get install lbreakout2
apt-get install xmame-sdl

Poi siccome mi va di sfidare veramente la sorte installo anche OpenOffice:

apt-get install openoffice.org

In fin dei conti non è male anche se il processore è praticamente sempre al massimo, soprattutto quando si avviano le applicazioni, ma anche Open Office riesce a partire ed a volte è perfino possibile usarlo 😛

mini_screenshot.png
Per internet non ci sono problemi, fatta eccezione per youtube, su cui vedere i video è praticamente impossible (1 MB di memoria video è veramente troppo poco).
Anche per la chat tutto OK.

E’ possibile ascoltare la musica, il piccolo altoparlante fa benissimo il suo dovere, se però nel frattempo si vuole fare qualsiasi altra attività la muscia inizia ad andare a scatti. 😦

Banditi assolutamente i video, tutti i player (xine, mplayer, ecc) si chiudevano dopo pochi secondi senza mostrare nemmeno un fotogramma.

Xmame parte ma è lentissimo e comunque la tecnologia con cui è realizzato il monitor non consente di giocare con questo pc: sembra che ci sia un effetto Motion Blur permanente 😛

In definitiva è stata una bella esperienza, quasi come buttarsi con il paracadute ad un pelo dalle rocce: te la fai sotto, però sai che adrenalina! 😛

A parte gli scherzi la stessa procedura è valida, seppur con qualche variazione, per installare Debian Etch su un Eee PC (in questo caso il boot può essere fatto da una memory stick anzichè dai floppy) 😉

Advertisements

~ di Morg4n su 15 febbraio, 2008.

13 Risposte to “Debian Horror: la notte dei morti viventi!!!”

  1. STIMA +10
    quasi quasi lo uso per rimettere su un po di sistemini vecchiotti… e utilizzarli per qualche cosa, anche se non so bene che cosa ancora 🙂

  2. Guarda guarda chi capita dalle parti di Morg4n’s Bay il grande Dimadj 😉

    Dai dai, che qualche cosa da farci con i vecchi PC si trova sempre 😉

    Ciao bello 😀

  3. io non ho la scheda di rete, ma ho il lettore cd. Come faccio ad installare debian? Scarico il cd dal sito e poi scelgo solo pochi pacchetti?
    Grazie, ciao.

  4. Si puoi scaricare direttamente le ISO dei CD (sono 21 CD) o dei DVD (sono 3 DVD) dal sito ufficiale, fai l’installazione e quando dovrai scegliere quali pacchetti installare puoi fare come ho fatto io dopo aver fumato la sigaretta 🙂

    P.S. Se non hai particolari esigenze è sufficiente scaricare la ISO del primo DVD per portare a termine l’installazione

  5. in alternativa puoi scaricare il CD “netinstall” e installare tutto quello che serve via rete.

  6. e il fantasma di Slackware non si è fatto vedere? 🙂

  7. Ogni tanto viene a tormentarmi nelle notti buie e tempestose 😛

  8. Complimenti prima di tutto, mi stò cimentando proprio con la stessa macchina ma ho un problema. fatto il boot non mi attiva la tastiera e quindi si blocca al primo enter. Hai qualche dritta da darmi??

  9. @Alessandro

    Hai provato a prenderla a pugni? Potrebbe essere un falso contatto… scherzo 😛

    Domanda banale: ma la tastiera funziona “da sola”? Mi spiego: prima ancora di aver caricato il primo floppy riesci, ad esempio, ad accedere al BIOS premendo CANC o F1 o F2 o F12 o quel cavolo che è 😛 (si divertono proprio a cambiare il tasto per accedere al BIOS).

    Se così non fosse potrebbe essere scollegata fisicamente: io proverei a sollevare la tastiera (attraverso le due linguette sotto al tasto di Windows e sotto Freccia Giù) e controllare il connettore.

    In alternativa pui collegare una tastiera alla porta PS/2 e procedere con l’installazione 😉

    Fammi sapere 😉

  10. prima di tutto grazie per la risposta e per i tempi
    la tentazione di prenderla a pugni era forte ma, mistero per per, con win95 funziona tutto, ma dopo tutto il boostrap del programma, ed è questo che non torna. provo con la tastiera esterna e ti faccio sapere, ma ho il dubbio che sia assente un comando di riconoscimento della periferica perchè non riesco ad accedere neppure al bios

  11. Ho questo PC con win95. Terribile… Ho letto della tua avventura e mi sono sganasciato dalle risate! Sei un grande! Complimenti. Paolo

  12. @Paolo
    Grazie mi fa piacere che ti sia piaciuto il post e mi hai fatto venire voglia di rileggerlo dopo più di un anno: quando mi ci metto ne sparo di cazzate 😛 ho riso anche io rileggendolo 😀

  13. anch’io ho questo pc e volevo chiederti se non potevi aiutarmi ad installarci “puppy”…….che pretese è?? ciao e grazie cmq

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

 
%d blogger hanno fatto clic su Mi Piace per questo: